Our News

Support for the old versions of Windows OS will be discontinued

 – 2017.06.07
Dear clients!

We want to inform you that due to the security vulnerability MetaTrader platform won't support the old versions of Windows OS from October 1, 2017. This change concerns the following operating systems: Windows XP, Windows 2003, Windows Vista. The old versions of MT4 and MT5 terminals will still work with the indicated systems, but won't get any updates from October 1, 2017.

The minimum requirements for the full-fledged work of MetaTrader 4/5 will be Windows 7 OS, but it is recommended to use 64-bit versions of Windows 10. Please сonsider this information while trading.

Kind regards,
JustForex team